Задать вопрос
30 июня, 04:36

С клавиатуры вводится символьная строка. Определите какой символ встречается в ней чаще всего

+1
Ответы (1)
  1. 30 июня, 07:50
    0
    Type

    index='0' ... 'z';

    var

    Ch:array[0 ... 255] of integer;

    s:string;

    i, max, imax:integer;

    begin

    { очищаем массив счетчиков }

    for i:=0 to 255 do Ch[i]:=0;

    Writeln ('Введите текст') ;

    Readln (s) ;

    for i:=1 to Length (s) do Inc (Ch[Ord (s[i]) ]) ;

    max:=Ch[0]; imax:=0;

    for i:=33 to 255 do { не рассматриваем непечатаемые символы и пробел}

    if max
    Writeln ('Символ "', Chr (imax),'" встретился ', max,' раз (а) ')

    end.

    Тестовое решение:

    Введите текст

    "Что значит имя? Роза пахнет розой, хоть розой назови её, хоть нет." (В. Шекспир)

    Символ "о" встретился 9 раз (а)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится символьная строка. Определите какой символ встречается в ней чаще всего ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)