Задать вопрос
18 мая, 00:32

Написать программу поиска любого элемента в массиве.

Для уточнения - на языке программирования, для программы Паскаль.

+5
Ответы (2)
  1. 18 мая, 00:59
    0
    Program pm;

    uses crt;

    var X:array[1 ... 1000] of integer; k, a, b, i:integer;

    begin

    clrscr;

    write ('Введите кол-во элементов массива: ') ;

    read (k) ;

    writeln;

    write ('Введите диапазон значений заполнения (A-начальное значение, B-конечное) : ') ;

    repeat

    read (a, b) ;

    until a<=b;

    writeln;

    randomize;

    for i:=1 to k do X[i]:=random (b-a+1) + a;

    writeln ('Ваш массив:') ;

    for i:=1 to k do write (X[i]:5) ;

    writeln;

    write ('Введите элемент поиска: ') ;

    read (b) ;

    a:=0;

    for i:=1 to k do if X[i]=b then a:=i;

    if a>0 then writeln ('Элемент со значением ', b,' имеет индекс ', a)

    else writeln ('Элемента не существует!') ;

    readkey;

    end.
  2. 18 мая, 02:10
    0
    Поиска индекса элемента по заданному значению или поиска значения по заданному индексу? Напишу решение для обоих случаев.

    1.

    Поиск элемента по заданному индексу

    var

    n:longint;

    m:array[1 ... 1000] of longint;

    begin

    writeln ('Введите индекс элемента массива') ;

    read (n) ;

    writeln ('Элемент под номером ', n,' равен ', m[n]) ;

    end.

    2. Поиск индекса по заданному значению в неупорядоченном массиве:

    var

    n, i:longint;

    m:array[1 ... 1000] of longint;

    begin

    read (n) ;

    i:=1;

    while m[i]n do

    i:=i+1;

    writeln (m[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу поиска любого элемента в массиве. Для уточнения - на языке программирования, для программы Паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
На Паскаль 1. С клавиатуры вводится число. Осуществить линейный поиск элемента в массиве. Вывести номер элемента, равного данному, либо сообщение о том, что такого элемента в массиве нет. 2.
Ответы (1)
1. Написать программу на языке программирования Паскаль, для вычисления значения выражения y=5x+6, если х любые числа и вводится с клавиатуры. 2.
Ответы (1)