Задать вопрос
13 декабря, 18:10

Напишите программу поиска всех четырёхзначных чисел, у которых все четыре цифры различны.

+4
Ответы (1)
  1. 13 декабря, 21:46
    0
    Var i, a, b, c, d, temp:integer;

    begin

    for i:=1000 to 9999 do

    begin

    temp:=i

    a:=temp div 1000;

    temp: = temp mod 1000;

    b:=temp div 100;

    temp: = temp mod 100;

    c:=temp div 10;

    d: = temp mod 10;

    if (ab) and (ac) and (ad) and (bc) and (bd) and (cd) then writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу поиска всех четырёхзначных чисел, у которых все четыре цифры различны. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Логическое "ИЛИ" называется? 1. логическая связка для поиска всех других слов, кроме указанного в запросе 2. логическая связка для поиска по всем словам 3. логическая связка для поиска по любому из слов Ответ:
Ответы (1)
Дано натуральное число n (n < 9999). Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр). Например, в числе 3678 все цифры различны, в числе 0023 - нет.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
в Паскале 1. Среди четырёхзначных чисел выбрать те, у которых все четыре цифры различны. 2. Дано шестизначное число n. Определить сколько раз в нём повторяется минимальная цифра. 3.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)