Задать вопрос
11 июня, 05:11

Написать программу, которая заменяет все заглавные буквы строчными, а строчные - заглавными в заданной символьной строке. (Паскаль)

+1
Ответы (1)
  1. 11 июня, 06:30
    0
    Program X; / / работает только для русских строк

    var

    i: longint;

    s: string;

    begin

    readln (s) ;

    for i : = 1 to length (s) do

    if (ord (s[i]) > = 192) and (ord (s[i]) < = 223) then

    s[i] : = chr (ord (s[i]) + 32)

    else if (ord (s[i]) > = 224) and (ord (s[i]) < = 255) then

    s[i] : = chr (ord (s[i]) - 32) ;

    writeln (s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая заменяет все заглавные буквы строчными, а строчные - заглавными в заданной символьной строке. (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике