Задать вопрос
20 апреля, 16:46

Напишите программу в turbo pascal: найти корни квадратного уравнения ax^2+bx+c

+2
Ответы (1)
  1. 20 апреля, 20:17
    0
    Var a, b, c, d, x, x1, x2:real;

    begin

    readln (a. b. c) ;

    d:=sqr (b) - 4*a*c;

    if d<0 then

    write ('нет корней')

    else

    If d=0 then begin

    x:=-b / (2*a) ;

    write (x) ; end

    else begin

    x1: = (-b+sqrt (d) / (2*a) ;

    x2: = (-b-sqrt (d)) / (2*a) ;

    write (x1, x2) ; end;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в turbo pascal: найти корни квадратного уравнения ax^2+bx+c ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Напишите программу в синтаксисе Free Pascal или Turbo Pascal, которая вычисляет выражение, состоящее из чисел и знаков (допускаются только знаки "+" или "-", количество чисел и знаков не ограничено).
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Помогите написать программу в turbo Pascal. Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10; 20].
Ответы (1)