Задать вопрос
10 ноября, 22:10

Pascal

1. Дано натурально число N. Получить его натуральные делители. 2. Определить, сколько чисел натурального ряда необходимо сложить, чтобы их сумма превысила число 119.3. Определить число, получаемое выписыванием в обратном порядке цифр заданного числа. (например, было 123, стало 321)

+4
Ответы (1)
  1. 11 ноября, 01:06
    0
    1. var i, n:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    begin

    if (n mod i = 0) then

    writeln (i) ;

    end;

    end.

    2.

    var shet1, count, sum:integer;

    begin

    shet1:=2;

    sum:=2;

    count:=1;

    while sum<=119 do

    begin

    count:=count+1;

    shet1:=shet1+1;

    sum:=sum+shet1;

    end;

    write ('count = ', count) ;

    end.

    3.

    var a:integer;

    begin

    read (a) ;

    while (a 0)

    do

    begin

    write (a mod 10) ;

    a : = a div 10;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal 1. Дано натурально число N. Получить его натуральные делители. 2. Определить, сколько чисел натурального ряда необходимо сложить, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано целое положительное трехзначное число. Напишите программу, позволяющую определить число, полученное выписыванием в обратном порядке цифр заданного трехзначного числа. Например: 123->321.
Ответы (1)
Ввести число N. Вывести число, получаемое выписыванием в обратном порядке цифр числа N. (Например, 1234, результат 4321). pascal цикл while или repeat
Ответы (2)
Определить число полученное выписыванием в обратном порядке цифр заданного целого трехзначного числа
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)