Задать вопрос
22 мая, 20:38

Нужно написать программу, что бы буквы заменялись на на "заглавные", а не те, что стоят перед ними в английском алфавите. PascalABC

Program eX_1;

var s: String;

n, i, b, j: longint;

c: char;

begin

writeln ('Введи текст из сообщения выше:') ;

readln (s) ;

for i:=length (s) downto 1 do

if s[i] in ['a' ... 'z'] then s[i]:=Upcase (s[i])

else if s[i] in ['A' ... 'Z'] then s[i]:=chr (ord (s[i]) + 32)

else if s[i] in ['0' ... '9'] then delete (s, i, 1) ;

write (s) ;

end.

+5
Ответы (1)
  1. 22 мая, 22:09
    0
    Program eX_1;

    var s: String; n, i, b, j: longint; c: char;

    begin

    writeln ('Введи текст из сообщения выше:') ;

    readln (s) ; for i:=length (s) downto 1 do

    if s[i] in ['b' ... 'z'] then s[i]:=chr (ord (s[i]) - 1)

    else if s[i]='a'then s[i]:='z';

    write (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно написать программу, что бы буквы заменялись на на "заглавные", а не те, что стоят перед ними в английском алфавите. PascalABC Program ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы