Задать вопрос
30 июля, 17:05

Написать программу в Pascal

числа a, b и c вводятся с клавиатуры. найти max (a, a+b) + max (a, b+c) / 1+max (a+b*c, 1,5)

+1
Ответы (2)
  1. 30 июля, 18:41
    0
    Function max (var first, second:real) : real;

    begin

    if first > second then max:=first else max: = second;

    end;

    var a, b, c, y : real;

    begin

    writeln ('Ведите a, b, c через пробел и нажмите Enter: ') ;

    read (a, b, c) ;

    y: = max (a, a+b) + max (a, b+c) / 1+max (a+b*c, 1.5) ;

    writeln ('Ответ: ', y) ;

    end.
  2. 30 июля, 20:17
    0
    Уверен, что формула в условии написана неверно, но уж как написано ...

    var

    a, b, c:real;

    begin

    Write ('Введите a, b, c: ') ; Read (a, b, c) ;

    Writeln ('Результат: ', max (a, a+b) + max (a, b+c) / 1+max (max (a+b*c, 1),5))

    end.

    Тестовое решение:

    Введите a, b, c: - 3 5.5 4

    Результат: 31

    А вот так, на мой взгляд, должно быть:

    var

    a, b, c:real;

    begin

    Write ('Введите a, b, c: ') ; Read (a, b, c) ;

    Writeln ('Результат: ', (max (a, a+b) + max (a, b+c)) / (1+max (a+b*c, 1.5)))

    end.

    Тестовое решение:

    Введите a, b, c: - 3 5.5 4

    Результат: 0.6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Pascal числа a, b и c вводятся с клавиатуры. найти max (a, a+b) + max (a, b+c) / 1+max (a+b*c, 1,5) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль Как написать программу, которая уменьшала бы ВСЕ максимальные элементы в два раза? Так? max:=a[1,1]; if a[i, j] > max then max: = a[i, j]; end; max: = max div 2;
Ответы (2)
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)