Задать вопрос
8 января, 14:44

Написать программу. заданы 4 числа. найти среднее арифметическое и среднее геометрическое этих чисел.

+2
Ответы (1)
  1. 8 января, 15:28
    0
    Vara, b, c, d:integer;

    sr_ar, sr_gm:real;

    begin

    read (a, b, c, d) ;

    sr_ar: = (a+b+c+d) / 4;

    sr_gm:=power (a*b*c*d, 1/4) ;

    writeln (sr_ar,' ', sr_gm) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу. заданы 4 числа. найти среднее арифметическое и среднее геометрическое этих чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Линейные алгоритмы. 1. Даны три действительных положительных числа. Найти среднее геометрическое и среднее арифметическое этих чисел. Условный оператор if. 2. Заданы два числа х, у. Меньшее из двух значений заменить на 0.
Ответы (1)
Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух положительных чисел X и Y (X и Y - входные, AMean и GMean - выходные параметры вещественного типа).
Ответы (1)
Создать программы в Паскале: 1. Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел. 2. Вычислить расстояние между двумя точками с заданными координатами (х1, у2) и (х2, у2)
Ответы (1)
Даны 2 числа. найдите среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.
Ответы (1)
Последовательно ввести N чисел. Найти среднее арифметическое, среднее геометрическое, среднее гармоническое (3 способа)
Ответы (1)