Задать вопрос
15 июля, 23:39

Дано 4579 число. Получить числа, образованные при перестановкой цифр заданного числа. (написать программу на паскале)

+2
Ответы (1)
  1. 16 июля, 03:34
    0
    Var abcd, a, b, c, d:integer;

    begin

    abcd:=4579;

    a:=abcd div 1000;

    b:=abcd div 100 mod 10;

    c:=abcd div 10 mod 10;

    d:=abcd mod 10;

    Writeln (a, b, c, d) ;

    Writeln (a, c, b, d) ;

    Writeln (b, a, c, d) ;

    Writeln (b, c, a, d) ;

    Writeln (c, a, b, d) ;

    Writeln (c, b, a, d) ;

    Writeln (a, d, b, c) ;

    Writeln (a, d, c, b) ;

    Writeln (b, d, a, c) ;

    Writeln (b, d, c, a) ;

    Writeln (c, a, d, b) ;

    Writeln (c, b, d, a) ;

    Writeln (a, b, d, c) ;

    Writeln (a, c, d, b) ;

    Writeln (d, b, a, c) ;

    Writeln (d, b, c, a) ;

    Writeln (d, c, a, b) ;

    Writeln (d, c, b, a) ;

    end.

    Громозко, да? Я не помню, как делать это через функцию. Думаю, и так сойдет.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 4579 число. Получить числа, образованные при перестановкой цифр заданного числа. (написать программу на паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)
Написать программу в паскале: Дано трехзначное число. Найти число, полученное перестановкой первой и третьей цифры заданного числа.
Ответы (2)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Дано натуральное четырехзначное число найти число, полученное перестановкой 2 и 3 цифр заданного числа. Составить в Pascal при помощи div и mod
Ответы (1)