Задать вопрос
10 марта, 13:56

Дана квадратная матрица порядка M. Заменить нулями элементы матрицы, лежащие выше побочной диагонали. как делает на delhpi

+3
Ответы (1)
  1. 10 марта, 16:20
    0
    Program Nuli;

    uses Crt;

    const M=8;

    type Mat = array [1 ... M, 1 ... M] of integer;

    var i, j: integer;

    A: Mat;

    begin

    ClrScr;

    WriteLn ('Old Massiv:') ;

    for i:=1 to M do

    begin

    for j:=1 to M do

    begin

    A[i, j]:=10+random (90) ;

    Write (A[i, j]:4) ;

    end;

    WriteLn;

    end;

    WriteLn;

    WriteLn ('New Massiv:') ;

    for i:=1 to M do

    for j:=1 to M do

    if j< = (M-i) then A[i, j]:=0;

    for i:=1 to M do

    begin

    for j:=1 to M do

    begin

    Write (A[i, j]:4) ;

    end;

    WriteLn;

    end;

    WriteLn;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана квадратная матрица порядка M. Заменить нулями элементы матрицы, лежащие выше побочной диагонали. как делает на delhpi ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана квадратная матрица порядка M. Обнулить элементы матрицы, лежащие выше побочной диагонали. Условный оператор не использовать. Pascal ABC
Ответы (1)
помогите люди)). Дана квадратная целочисленная матрица размера 4 х4. Заменить нулями элементы матрицы, лежащие на главной диагонали. В bordland paskal. задача на двумерный массив
Ответы (1)
Помогите написать программу в pascal'e. Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали. В противном случае-заменить элементы четных строк нулями.
Ответы (1)
Pascal Дана квадратная матрица порядка М. Обнулите элементы матрицы, лежащие ниже главной диагонали. Условный оператор не использовать.
Ответы (1)
Помогите решить задачку (Паскаль) Дана матрица B (4,4) 1) Найти произведение положительных элементов среди элеметов рассположенных выше побочной диагонали матрицы B. 2) Найти минимальный элемент во втором столбце матрицы B.
Ответы (1)