Задать вопрос
4 марта, 04:09

Как вывести число натуральных чисел-палиндромов от a до b (a, b не превышают 10000) в пфскале

+5
Ответы (1)
  1. 4 марта, 06:35
    0
    Var

    a, b, i, n, j, l, ier:integer;

    s:string;

    p:boolean;

    begin

    Write ('Введите границы интервала в виде пары натуральных чисел ') ;

    Read (a, b) ;

    n:=0;

    for i:=a to b do

    begin

    Str (i, s) ;

    l:=Length (s) ;

    if l=1 then Inc (n)

    else begin

    j:=1;

    repeat

    p: = (s[j]=s[l-j+1]) ;

    Inc (j)

    until (j>l) or (not p) ;

    if p then Inc (n)

    end

    end;

    Writeln ('Количество палиндромов равно ', n)

    end.

    Тестовое решение:

    Введите границы интервала в виде пары натуральных чисел 1550 2450

    Количество палиндромов равно 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как вывести число натуральных чисел-палиндромов от a до b (a, b не превышают 10000) в пфскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)