Задать вопрос
1 октября, 18:45

Некто продает свою лошадь по числу подковных гвоздей, которых у него 16. За первый гвоздь он просит 1 коп., за второй - 2, за третий - 4 за четвертый - 8

и всегда за каждый следующий вдвое больше, чем за предыдущий. Спрашивается, во сколько он ценит лошадь?

Решение в паскале.

+2
Ответы (1)
  1. 1 октября, 20:31
    0
    Var s, i, c:integer;

    begin

    s:=0;

    c:=1;

    for i:=1 to 16 do begin

    s+=c;

    c*=2;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Некто продает свою лошадь по числу подковных гвоздей, которых у него 16. За первый гвоздь он просит 1 коп., за второй - 2, за третий - 4 за ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Человек покупает коня, но недоволен ценой в 1000 рублей. Продавец ему предлагает платить не за коня, а за подковные гвозди: копейка за первый, две за второй, четыре за третий и так далее (за каждый следующий гвоздь в два раза больше, чем за
Ответы (1)
4 школьника посещали кинотеатр. Первый бывал в нем каждый четвертый день, второй - каждый пятый, третий - каждый седьмой, четвертый - каждый девятый.
Ответы (1)
Определите максимальное число учеников, сдавших экзамен при условии, что: 1. если первый сдал, то и второй сдал; 2. если второй сдал, то третий сдал или первый не сдал; 3. если четвертый не сдал, то первый сдал, а третий не сдал; 4.
Ответы (1)
Определить, кто из четырех студентов сдал экзамен, если известно: 1) Если первый сдал, то и второй сдал; 2) Если второй сдал, то третий сдал или первый не сдал; 3) Если четвертый не сдал, то первый сдал, а третий не сдал;
Ответы (1)
Почему Foxit Reader просит удалить страую версию он просит нажать на ок типо удалить я удаляю и просит повторить и так несколько раз?
Ответы (1)