Задать вопрос
5 августа, 02:40

Вычислить сумму тех чисел из заданного отрезка [a, b] (a, b - натуральные), в запись которых входит цифра k. (тема: Процедуры в языке Pascal)

+1
Ответы (1)
  1. 5 августа, 05:13
    0
    Function HasK (n:longint; k:char) : boolean;

    { возвращает true, если в числе n имеется цифра 'k' }

    var ns:string;

    begin

    Str (n, ns) ; { переходим к символьному изображению числа }

    HasK: = (Pos (k, ns)) >0

    end;

    var

    a, b, i, kol:longint;

    k:char;

    begin

    Write ('Введите интервал чисел: ') ; Readln (a, b) ;

    Write ('Введите искомую цифру: ') ; Readln (k) ;

    kol:=0;

    for i:=a to b do

    if HasK (i, k) then kol:=kol+1;

    Writeln ('Количество чисел с цифрой ', k,': ', kol)

    end.

    Тестовое решение:

    Введите интервал чисел: 136 523

    Введите искомую цифру: 5

    Количество чисел с цифрой 5: 96
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму тех чисел из заданного отрезка [a, b] (a, b - натуральные), в запись которых входит цифра k. (тема: Процедуры в языке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Вася изучал сегодня на информатике тему "Рекурсия". После урока на доске осталась такая функция (для условия на языке Pascal - процедура) : на языке Python: def f (n) : print ('*') if n > 2: f (n - 1) f (n - 2) на языке Pascal: procedure f (n:
Ответы (1)