Задать вопрос
8 сентября, 05:36

Написать программу на ABC Pascal:

Дан текстовый файл f. Найти слова, заканчивающие на of

+3
Ответы (1)
  1. 8 сентября, 08:16
    0
    Const

    n=50;

    var

    f:Text;

    s:string;

    ss:array of string;

    a:array[1 ... n] of string;

    i, j:integer;

    begin

    Assign (f,'input. txt') ; Reset (f) ;

    j:=0;

    while not Eof (f) do begin

    Readln (f, s) ;

    ss:=s. Split (' ') ;

    for i:=0 to Length (ss) - 1 do

    if Length (ss[i]) >1 then

    if RightStr (ss[i],2) = 'of' then

    begin Inc (j) ; a[j]:=ss[i] end;

    end;

    Close (f) ;

    for i:=1 to j do Write (a[i],' ') ;

    Writeln

    end.

    Тестовое решение:

    123of asdfdsof dasof

    Есть решение и покороче, но совсем не уровня начинающих:

    uses

    System. Text. RegularExpressions;

    const

    n=50;

    var

    f:Text;

    s:string;

    a:array[1 ... n] of string;

    i, j:integer;

    begin

    Assign (f,'input. txt') ; Reset (f) ;

    j:=0;

    while not Eof (f) do begin

    Readln (f, s) ;

    foreach var m:Match in Regex. Matches (s,'/b/S+of/b') do

    begin Inc (j) ; a[j]:=m. Value end;

    end;

    Close (f) ;

    for i:=1 to j do Write (a[i],' ') ;

    Writeln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на ABC Pascal: Дан текстовый файл f. Найти слова, заканчивающие на of ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите! 1. Web-страница (документ html) представляет собой: 1) текстовый файл с расширением txt или doc 2) текстовый файл с расширением htm или html 3) двоичный файл с расширением com или exe 4) графический файл с расширением gif или jpg
Ответы (2)
Pascal ABC Дан текстовый файл t1. txt, содержащий целые числа, не превышающие 30000. Найти длину самой длинной цепочки одинаковых чисел, идущих подряд в файле t1. txt и записать эту цепочку в файл t2.
Ответы (1)
Дан текстовый файл. Необходимо переписать его содержимое в другой текстовый файл, добавляя в начало каждой строки её порядковый номер (десятичную запись целого числа шириной в 5 символов, выровненную по правой границе поля) и пробел.
Ответы (1)
Дан текстовый файл с именем input. txt в первой строке которого записано натуральное число N, а во второй строке N целых чисел. Переписать в файл с именем a. dat числа, кратные 100 из исходного файла, а в файл с именем b.
Ответы (1)
Создать текстовый файл f1. Конкатенировать файл f 1 самого с собой, только записанного задом наперед и результат записать в файл f2. Вывести на экран файл f 2.
Ответы (1)