Задать вопрос
18 февраля, 14:43

Написать программу на Pacal

задачи:

1. Дано два ненулевых числа проверить истинность высказывания "числа имеют разные знаки".

2. Дано два целых числа проверить истинность высказывания " оба числа четные".

+2
Ответы (1)
  1. 18 февраля, 17:12
    0
    1.

    var a, b:integer;

    begin

    readln (a) ;

    readln (b) ;

    if ((a>0) and (b>0)) Or ((a<0) and (b<0))

    writeln ('У обоих чисел одинаковые знаки')

    else

    writeln ('У чисел разные знаки') ;

    end.

    2.

    var a, b:integer;

    begin

    readln (a) ;

    readln (b) ;

    if (a mod 2=0) And (b mod 2=0) then

    writeln ('Высказывание истинно')

    else

    writeln ('Высказывание ложно')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Pacal задачи: 1. Дано два ненулевых числа проверить истинность высказывания "числа имеют разные знаки". 2. Дано два ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите надо написать программу в паскале. 1) координаты двух различных полей шахматной доски x1, y1, x2, y2 (целые числа, лежащие в диапазоне 1-8). Проверить истинность высказывания: "Ладья за один ход может перейти с одного поля на другое".
Ответы (1)
Ребят помогите с задачей в Pacal. Натуральное число называется палиндромом, если его запись читается одинаково с начала и с конца (например: 1,22,393). Найти все меньшие 100 натуральные числа, которые при возведении в квадрат дают палиндром.
Ответы (1)
Вводятся два натуральных числа. если оба числа чётные, то вывести большее из них. если оба числа не чётные, то вывести меньшее из них. если одно чётное, а другое не чётное, то вывести их произведение на экран.
Ответы (2)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3.
Ответы (1)