Задать вопрос
25 июля, 18:19

Написать программу, определяющую по координатам трёх точек длины биссектрис треугольника, если таковой существует. (PascalABC)

+3
Ответы (1)
  1. 25 июля, 20:51
    0
    Var x:Array[1 ... 3] of integer; / / координаты точекy:Array[1 ... 3]of integer; / / координаты точекs:Array[1 ... 3]of real; / / расстояние между точками b:Array[1 ... 3]of real; / / длина бессектрисы p: real; beginfor var i: = 1 to 3 dobegin write ('Введите координаты ', i,' точки') ; readln (x[i], y[i]) ; end; writeln ('Начало расчетов') ; for var i: = 1 to 3 dobegin

    if (i < 3) then begin s[i] : = sqrt ((x[i]-x[i+1]) * (x[i]-x[i+1]) + (y[i]-y[i+1]) * (y[i]-y[i+1])) ; p : = p + s[i]; end else begin s[i] : = sqrt ((x[i]-x[1]) * (x[i]-x[1]) + (y[i]-y[1]) * (y[i]-y[1])) ; p : = p + s[i]; end;

    writeln ('Расстояние между ', i,' и ', i+1,' точками = ', s[i]) ; end; p : = p / 2; writeln ('полупериметр = ', p) ; for var i: = 1 to 3 do beginif (i = 1) then b[i] : = 2 * sqrt (s[1]*s[2]*p * (p - s[3])) / (s[1]+s[2]) ; if (i = 2) then b[i] : = 2 * sqrt (s[2]*s[3]*p * (p - s[1])) / (s[2]+s[3]) ; if (i = 3) then b[i] : = 2 * sqrt (s[3]*s[1]*p * (p - s[2])) / (s[3]+s[1]) ; writeln ('Длина ', i, ' бессиктрисы ', b[i]) ; end; end.//определяющую по координатам трёх точек длины биссектрис треугольника, / / если таковой существует. (PascalABC)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, определяющую по координатам трёх точек длины биссектрис треугольника, если таковой существует. (PascalABC) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Помогите нужно использовать программу PascalABC Вариант 2 Программа PascalABC Кровяное давление у старшеклассников считается нормальным, если верхняя его граница H ≤ 100, а нижняя h ≥ 60 и H-h ≥ 30.
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)