Задать вопрос
5 июня, 10:48

Написать программу на языке Си для вычисления значений следующих выражений:

a=5, c=5

a=a+b-2

c=c+1, d=c-a+d

a=a*c, c=c-1

a=a/10, c=c/2, b=b-1, d=d * (c+b+a)

Выражения, записанные в одной строке, записывать одним оператором-выражением. Переменные c и d объявить как целые, переменные a и b - как вещественные. Значения переменных b и d вводить с клавиатуры. После вычисления каждого выражения выводить на экран значения всех переменных.

+3
Ответы (1)
  1. 5 июня, 13:00
    0
    Я конечно не особо программист, но это вроде работает

    #include

    int main () {

    float a=5, c=5;

    int b, d;

    printf ("Здравствуйте! Введите 2 числа:/n") ;

    scanf ("%d",&b) ; scanf ("%d",&d) ;

    a + = b-2;

    d + = c-a-1;

    a = a*c-1;

    a = a/10;

    c = c/2;

    b--;

    d = d * (c+b+a) ;

    printf ("В итоге получилось:%F,%F,%d,%d",&a,&b,&c,&d) ;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Си для вычисления значений следующих выражений: a=5, c=5 a=a+b-2 c=c+1, d=c-a+d a=a*c, c=c-1 a=a/10, c=c/2, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Числа в языке Pascal различаются: А) как натуральные и целые; Б) как целые и вещественные; В) как натуральные и вещественные; Г) как целые и иррациональные; Д) как целые и рациональные.
Ответы (1)
Составить программу, которая будет вводить пять целых чисел с клавиатуры и выводить на экран только те, которые принадлежат интервалам (0,5) и (-1,-8), либо выводить соответствующее сообщение.
Ответы (1)
1) Напишите программу "Конвертер валют". Вводим сумму в тенге, на экран выводится сумма в долларах, рублях, евро 2) Поменять значения двух переменных местами: Например: int a = 5; int b = 4; Нужно, чтобы a стало равно 4, а b - 5.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Задания. 1. Найти простейшую формулу от трёх переменных, принимающую значение 0 только на следующих наборах значений переменных: 7) А (0,0,0) = А (0,1,1) = А (1,0,1) = А (1,1,1) 2.
Ответы (1)