Задать вопрос
17 ноября, 23:21

Определить, все ли цифры натурального числа n одинаковы.

+2
Ответы (1)
  1. 18 ноября, 02:15
    0
    Pascal

    var

    a, b : integer;

    r : boolean;

    begin

    readln (a) ;

    r : = true;

    b : = a mod 10;

    While a > 0 do

    begin

    if a mod 10 b then

    begin

    r : = false;

    a : = 0;

    end;

    a : = a div 10;

    end;

    if r then

    writeln ('Все цифры числа одинаковы')

    else

    writeln ('Цифры числа различны') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, все ли цифры натурального числа n одинаковы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Найти все простые делители натурального числа N. Входные данные: Ввести одно число N (1
Ответы (1)
Python! Напишите программу, которая получает с клавиатуры трёхзначное число и записывает в логическую переменную значение "да" (True), если это все его цифры одинаковы.
Ответы (1)
1 задача. Даны 3 числа (a, b, c). Возвести в квадрат те, которые меньше 5 и в куб меньше 5 2 задача. Даны 4 числа определить колличество отрицательных 3 задача. Дано двухдверное число Определить одинаковы ли его цифры.
Ответы (1)
Нарисуй в окне цепочку П из пяти цифр так, чтобы все пять утверждений были истенными: В цепочке П цифра 3 идет раньше цифры 9. В цепочке П цифра 2 идет позже цифры 6. В цепочке П цифра 6 идет раньше цифры 9. В цепочке П цифра 6 идет позже цифры 5.
Ответы (1)