Задать вопрос
28 июня, 10:36

Удалить часть символьной строки, заключенной в скобки (вместе со скобками).

+4
Ответы (1)
  1. 28 июня, 11:07
    0
    Uses Crt;

    var

    s:string;

    i, j:integer;

    begin

    Writeln ('Vvedite stroku: ') ;

    Readln (s) ;

    i:=Pos (' (', s) ; j:=Pos (') ', s) ;

    if (i>0) and (j>0) and (j>i) then

    s:=Copy (s, 1, i-1) + Copy (s, j+1, Length (s) - j) ;

    Writeln ('Resultat: ', s) ;

    ReadKey

    end.

    Тестовое решение:

    Vvedite stroku:

    3*a-1 / (2*a-5) / 2

    Resultat: 3*a-1//2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Удалить часть символьной строки, заключенной в скобки (вместе со скобками). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово - это последовательность непробельных символов, ограниченная пробелами или концами строки.
Ответы (1)
Составьте программу которая позволяет удалить слово t из строки s. Строка s и слово t, которое надо удалить, вводятся с клавиатуры
Ответы (1)
Составьте программу, которая позволяет удалить символы t из строки s. Строка s и символ t, который надо удалить, вводятся с клавиатуры
Ответы (1)
Дана строка, содержащая только английские буквы (большие и маленькие) и открывающиеся скобки. Сформировать новую строку добавлением справа "зеркальной" строки с закрывающимися скобками.
Ответы (1)
Введите строку. Удалить все символы, расположенные между круглыми скобками. (Примечание, В строке скобки расставлены правильно, нет вложенных скобок. Может быть несколько пар круглых скобок)
Ответы (1)