Задать вопрос
8 декабря, 22:51

7. Написать программу на pascal, которая обменивает первую и третью строку массива.

+1
Ответы (1)
  1. 9 декабря, 02:17
    0
    Const

    m = 5;

    n = 8;

    var

    a: array[1 ... m, 1 ... n] of integer;

    i, j, t: integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i : = 1 to m do

    begin

    for j : = 1 to n do

    begin

    a[i, j] : = Random (101) - 50;

    Write (a[i, j]:4)

    end;

    Writeln

    end;

    for j:=1 to n do begin t:=a[1, j]; a[1, j]:=a[3, j]; a[3, j]:=t end;

    Writeln ('Полученный массив') ;

    for i : = 1 to m do

    begin

    for j : = 1 to n do Write (a[i, j]:4) ;

    Writeln

    end

    end.

    Тестовое решение:

    Исходный массив

    45 20 - 15 33 - 37 26 - 30 - 3

    -27 43 - 24 4 - 14 18 - 50 5

    -28 - 47 11 27 - 8 42 - 19 - 39

    16 43 - 18 0 - 32 25 11 22

    27 - 37 - 44 - 38 - 50 7 - 45 - 30

    Полученный массив

    -28 - 47 11 27 - 8 42 - 19 - 39

    -27 43 - 24 4 - 14 18 - 50 5

    45 20 - 15 33 - 37 26 - 30 - 3

    16 43 - 18 0 - 32 25 11 22

    27 - 37 - 44 - 38 - 50 7 - 45 - 30
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «7. Написать программу на pascal, которая обменивает первую и третью строку массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)