Задать вопрос
13 августа, 16:56

На языке Паскаль.

Заполнить матрицу случайными числами. Размерность и диапазон генерации ввести с клавиатуры. Вычислить произведение элементов массива, лежащих вне главной диагонали.

+3
Ответы (1)
  1. 13 августа, 17:38
    0
    Program primer;

    procedure random (c, x, y:integer; var r:integer) ;

    begin

    case c of

    1 : r:=Random (ABS (Y) + ABS (x) + 1) + x;

    2 : r:=Random (ABS (Y) + ABS (x) + 1) + y;

    3 : r:=Random (Y-x+1) + x;

    4 : r:=Random (x-y+1) + y;

    5 : r:=Random (x+y) ;

    6 : r:=Random (ABS (x+y)) - ABS (x+y) ;

    7 : r:=x;

    8 : r:=Random (ABS (ABS (x) - ABS (y))) - ABS (x) ;

    9 : r:=Random (ABS (ABS (x) - ABS (y))) - ABS (y) ;

    end;

    end;

    var

    a: array of array of integer;

    i, j, x, y, m, p, pro, c:integer; begin

    Randomize;

    pro:=1;

    writeln ('Кол-во строк и столбцов массива? / / X, Y / / ') ;

    read (i, j) ; / / Размерность массива

    writeln ('Диапазон чисел / / от X, до Y / / ') ;

    read (x, y) ; / / и диапазон генерации вводятся с клавиатуры.

    if (x=y) then

    c:=7

    else

    if (x<0) and (y<0) then

    if (x
    c:=8

    else

    c:=9

    else

    if (x=0) or (y=0) then

    if (x<0) or (y<0) then

    c:=6

    else

    c:=5

    else

    if (x<0) or (y<0) then

    if (x
    c:=1

    else

    c:=2

    else

    if (x
    c:=3

    else

    c:=4;

    SetLength (a, i) ;

    for m:=0 to i-1 do

    SetLength (a[m], j) ;

    for m:=0 to i-1 do begin

    writeln () ;

    for p:=0 to j-1 do begin

    random (c, x, y, a[m, p]) ; {Заполнить матрицу случайными числами }

    if (mp) then pro:=pro*a[m, p]; { Вычислить произведение элементов массива, лежащих вне главной диагонали.}

    write (a[m, p]:3,' ':3) ;

    end;

    end;

    writeln ('pro=', pro) ;

    a:=NIL;

    end.

    / / ABC Pascal
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На языке Паскаль. Заполнить матрицу случайными числами. Размерность и диапазон генерации ввести с клавиатуры. Вычислить произведение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заполнить двумерный массив случайными числами. Размерность массива и диапазон генерации вводятся с клавиатуры. Составить программу, которая вычисляет сумму всех элементов массива.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)