Задать вопрос
14 октября, 22:38

Заполнить двумерный массив случайными числами. Размерность массива и диапазон генерации вводятся с клавиатуры. Составить программу, которая вычисляет сумму всех элементов массива.

Затем организовать новый массив В, в котором заменить отрицательные элементы исходного массива на 1, а значения остальных элементов оставить без изменения. Подсчитать количество замен.

+4
Ответы (1)
  1. 15 октября, 01:57
    0
    Program primer;

    procedure random (c, x, y:integer; var r:integer) ;

    begin

    case c of

    1 : r:=Random (ABS (Y) + ABS (x) + 1) + x;

    2 : r:=Random (ABS (Y) + ABS (x) + 1) + y;

    3 : r:=Random (Y-x+1) + x;

    4 : r:=Random (x-y+1) + y;

    5 : r:=Random (x+y) ;

    6 : r:=Random (ABS (x+y)) - ABS (x+y) ;

    7 : r:=x;

    8 : r:=Random (ABS (ABS (x) - ABS (y))) - ABS (x) ;

    9 : r:=Random (ABS (ABS (x) - ABS (y))) - ABS (y) ;

    end;

    end;

    var

    a, b: array of array of integer;

    i, j, x, y, c, m, p, sum:integer; begin

    Randomize;

    sum:=0;

    writeln ('Кол-во строк и столбцов массива? / / X, Y / / ') ;

    read (i, j) ; / / Размерность массива

    writeln ('Диапазон чисел / / от X, до Y / / ') ;

    read (x, y) ; / / и диапазон генерации вводятся с клавиатуры.

    if (x=y) then

    c:=7

    else

    if (x<0) and (y<0) then

    if (x
    c:=8

    else

    c:=9

    else

    if (x=0) or (y=0) then

    if (x<0) or (y<0) then

    c:=6

    else

    c:=5

    else

    if (x<0) or (y<0) then

    if (x
    c:=1

    else

    c:=2

    else

    if (x
    c:=3

    else

    c:=4;

    SetLength (a, i) ;

    for m:=0 to i-1 do

    SetLength (a[m], j) ;

    SetLength (b, i) ;

    for m:=0 to i-1 do

    SetLength (b[m], j) ;

    for m:=0 to i-1 do begin

    writeln () ;

    for p:=0 to j-1 do begin

    random (c, x, y, a[m, p]) ; {Заполнить двумерный массив случайными числами.}

    sum:=sum+a[m, p]; {вычисляет сумму всех элементов массива}

    write (a[m, p]:3,' ':3) ;

    end;

    end;

    c:=0;

    writeln ('summa=', sum) ;

    for m:=0 to i-1 do begin {Затем организовать новый массив В }

    writeln () ;

    for p:=0 to j-1 do begin

    if (a[m, p] <0) then begin

    b[m, p]:=1; {в котором заменить отрицательные элементы исходного массива на 1} inc (c) ; {Подсчитать количество замен. }

    end

    else

    b[m, p]:=a[m, p]; {а значения остальных элементов оставить без изменения }

    write (b[m, p]:3, ' ':3) ;

    end;

    end;

    writeln ('kol=', c) ;

    a:=NIL;

    b:=NIL;

    end.

    / / ABC Pascal
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить двумерный массив случайными числами. Размерность массива и диапазон генерации вводятся с клавиатуры. Составить программу, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)