Задать вопрос
13 июля, 17:23

1) напишите функцию вычисляющую количество трехзначных чисел делящихся на 13 и не оканчивающихся на 3

2) для некоторого массива из 30 элементов, проверить, есть-ли в массиве элемент, заданному значению с клавиатуры

+5
Ответы (1)
  1. 13 июля, 20:12
    0
    Pacal

    function F () : integer;

    var

    k, i : integer;

    begin

    k : = 0;

    for i : = 100 to 999 do

    if (i mod 13 = 0) and (i mod 100 3) then

    k : = k + 1;

    Result : = k;

    end;

    begin

    writeln (f ()) ;

    end.

    const

    n = 30;

    var

    a : array [1 ... n] of integer;

    i, b : integer;

    r : boolean;

    begin

    readln (b) ;

    i : = 1;

    r : = false;

    While (not r) and (i < = n) do

    begin

    if a[i] = b then

    r : = true;

    i : = i + 1;

    end;

    if r then

    writeln ('Есть')

    else

    writeln ('Нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) напишите функцию вычисляющую количество трехзначных чисел делящихся на 13 и не оканчивающихся на 3 2) для некоторого массива из 30 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)