Задать вопрос
8 мая, 00:24

Составьте программу либо через функцию или можно через процедуру:

1) Вычислить сумму квадратов простых чисел, лежащих в интервале (M, N).

2) Вычислить сумму простых не превосходящих заданного числа N.

+4
Ответы (1)
  1. 8 мая, 01:52
    0
    Var

    n, m:integer;

    procedure summa (a, b:integer) ;

    var res:integer;

    begin

    while a<=b do

    begin

    res: = (a*a) + res;

    a:=a+1;

    end;

    writeln (res) ;

    end;

    begin

    readln (n, m) ;

    summa (n, m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу либо через функцию или можно через процедуру: 1) Вычислить сумму квадратов простых чисел, лежащих в интервале (M, N). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Заполнить массив А (13) датчиком случайных чисел в интервале от 0 до 40 определить количество элементов массива не превосходящих по величине число В число В задается датчиком случайных чисел в интервале от 0 до 20
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)