Задать вопрос
4 мая, 00:25

Дан двухмерный массив "у" с размерностью n x m если все элементы строки четные, то вывести порядковый номер строки.

в паскале

написать программу

+4
Ответы (1)
  1. 4 мая, 00:54
    0
    Var

    y:array[1 ... 999, 1 ... 999] of integer;

    i, j, n, m:integer;

    chet:boolean;

    begin

    randomize;

    readln (n, m) ;

    //Рандомно заполняем и выводим двумерный массив числами от 0 до 100

    for i:=1 to n do

    begin

    for j:=1 to m do begin

    y[i, j]:=random (101) ;

    write (y[i, j],' ') ;

    end;

    writeln;

    end;

    writeln;

    for i:=1 to n do

    begin

    chet:=true;

    for j:=1 to m do

    if y[i, j] mod 2 0 then

    chet:=false;

    if chet = true then

    write (i, ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двухмерный массив "у" с размерностью n x m если все элементы строки четные, то вывести порядковый номер строки. в паскале написать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1. Дан двухмерный массив A (n, m). Найти произведение отрицательных четных элементов второго столбца массива. 2. Дан двухмерный массив m*n. Получите одномерный массив b, элементы которого равны min элементам по строкам.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Дан массив. Напечатать: а) Все четные 1. Дан массив. Напечатать: а) Все четные элементы б) Все элементы, оканчивающиеся нулем. 2. В массиве хранится информация о количестве осадков, выпавших каждый день января.
Ответы (1)