Задать вопрос
4 мая, 13:01

Определите значение переменных х и у после выполнения фрагмента алгоритма:

а) Даны х и у

у:=у-х

х:=х-2

х больше у?

Если да, то конец

Если нет, то снова:

у:=у-х

х:=х-2

б) Даны х и у

у: у+х

х:=х-2

х=0?

Если да, то конец

Если нет, то снова:

у:=у+х

х:=х-2

+1
Ответы (1)
  1. 4 мая, 15:25
    0
    а)

    var x, y: integer;

    begin

    write ('Введите x: ') ;

    readln (x) ;

    write ('Введите y: ') ;

    readln (y) ;

    y : = y - x;

    x : = x - 2;

    if x < y then

    begin

    y : = y - x;

    x : = x - 2;

    end;

    writeln ('x = ', x) ;

    writeln ('y = ', y) ;

    end.

    б)

    var x, y: integer;

    begin

    write ('Введите x: ') ;

    readln (x) ;

    write ('Введите y: ') ;

    readln (y) ;

    y : = y + x;

    x : = x - 2;

    if x 0 then

    begin

    y : = y + x;

    x : = x - 2;

    end;

    writeln ('x = ', x) ;

    writeln ('y = ', y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите значение переменных х и у после выполнения фрагмента алгоритма: а) Даны х и у у:=у-х х:=х-2 х больше у? Если да, то конец Если ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 8673; b: = (a mod 100) * 10 + 14;
Ответы (1)
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Помогите решить 1 написание блок-схему цикла для 2 дан линейный алгоритм а:=14; b:=8+a mod 6; a:=b*3 div 3 Чему равно значение переменных a и b после выполнения алгоритма 3 определите значение переменной после выполнения фрагмента алгоритма f:=
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)