Задать вопрос
11 октября, 16:47

Напишите программу на паскале abc которая вводит натуральное число N и выводит на экран все натуральные числа не превосходящие N и делящиеся на кадлую из своих цифр

+1
Ответы (1)
  1. 11 октября, 18:35
    0
    Var

    d: integer;

    i, k, n: longint;

    flag: boolean;

    begin

    Write ('Введите верхнюю границу для счета: ') ; Readln (k) ;

    for i : = 1 to k do

    begin

    n : = i;

    repeat

    d : = n mod 10;

    if d > 0 then flag : = ((i mod d) 0) else flag : = true;

    if (not flag) then n : = (n div 10)

    until (flag or (n = 0)) ;

    if n = 0 then Write (i, ' ')

    end;

    Writeln

    end.

    Тестовое решение:

    Введите верхнюю границу для счета: 1237

    1 2 3 4 5 6 7 8 9 11 12 15 22 24 33 36 44 48 55 66 77 88 99 111 112 115 122 124 126 128 132 135 144 155 162 168 175 184 212 216 222 224 244 248 264 288 312 315 324 333 336 366 384 396 412 424 432 444 448 488 515 555 612 624 636 648 666 672 728 735 777 784 816 824 848 864 888 936 999 1111 1112 1113 1115 1116 1122 1124 1128 1131 1144 1155 1164 1176 1184 1197 1212 1222 1224 1236
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на паскале abc которая вводит натуральное число N и выводит на экран все натуральные числа не превосходящие N и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Прошу подсказать в программе, у меня есть свой код, но он не правильный точно. Язык pascal Программа вводит натуральные числа a и b и выводит на экран все натуральные числа на отрезке [a, b] делящиеся на каждую из своих цифр var a, b, k, t, m, i, p,
Ответы (1)
Простые числа - это натуральные числа, которые делятся без остатка только на себя и на единицу: 2, 3, 5, 7, 11 ... 1) Разработайте программу, которая вводит число К и проверяет, является ли оно простым.
Ответы (1)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)