Задать вопрос
20 апреля, 10:38

Даны X, У. Найти квадратный корень из произведения X и У, вычислить случайное число в диапазоне [X, У), получить целую часть от частного X и У.

Составит программу на языке Паскаль

+4
Ответы (1)
  1. 20 апреля, 13:37
    0
    Var x, y: integer;

    rez: real;

    begin

    write ('Введите x: ') ;

    readln (x) ;

    write ('Введите y: ') ;

    readln (y) ;

    rez : = sqrt (x*y) ;

    writeln ('Квадратный корень произведения ', x, ' и ', y, ': ', rez) ;

    if x > y then rez : = random (X-2) + Y

    else rez : = random (Y-2) + X;

    writeln ('Случайное число из диапозона [ ', x, '; ', y, ') : ', rez) ;

    rez : = int (x / y) ;

    writeln ('Целая часть от частного Х и Y: ', rez) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны X, У. Найти квадратный корень из произведения X и У, вычислить случайное число в диапазоне [X, У), получить целую часть от частного X ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано".
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)