Задать вопрос
25 ноября, 11:40

Паскаль

Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента. Определите наибольшее число последовательности.

+5
Ответы (1)
  1. 25 ноября, 15:04
    0
    Попробуй так:

    uses Crt;

    var a, Max: real;

    i: integer;

    begin

    ClrScr;

    i:=0;

    Repeat

    i:=i+1;

    Write ('a', i,'=') ; ReadLn (a) ;

    if a0 then

    begin

    if a>Max then Max:=a;

    end;

    until a=0;

    WriteLn;

    WriteLn (' Max = ', Max:6:4) ;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)