Задать вопрос
11 ноября, 00:09

Найдите натуральные числа, не превосходящие n, которые делятся на каждую из своих цифр.

+2
Ответы (1)
  1. 11 ноября, 00:54
    0
    Var

    n, i, a, k:

    integer;

    f: boolean;

    begin

    readln (n) ;

    for i : = 1 to n do

    begin

    a : = i;

    f : = true;

    while a > 0 do

    begin

    k : = a mod 10;

    a : = a div 10;

    if (k = 0) or (i mod k 0) then / / если в числе есть 0, то считать что на 0 не делится, иначе замените = на

    f : = False;

    end;

    if f then

    write (i, ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите натуральные числа, не превосходящие n, которые делятся на каждую из своих цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в Паскале Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр.
Ответы (1)
Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр. Составить программу на паскале!
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)