Задать вопрос
29 февраля, 09:17

Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр. Составить программу на паскале!

+5
Ответы (1)
  1. 29 февраля, 12:38
    0
    Var

    N, B:longint;

    k:byte;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    For n: = 1 to n do

    Begin

    k:=1;

    B:=n;

    While B>0 do

    Begin

    if B mod 100 then

    Begin

    if n mod (B mod 10) 0 then k:=0

    End

    else k:=0;

    B:=B div 10

    End;

    if k=1 then Write (n,' ')

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр. Составить программу на паскале! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике