Задать вопрос
20 июня, 06:06

С клавиатуры вводится текст. Слова разделяются пробелом. Ввод текста прекращается после нажатия на клавиатуре точки. Посчитать количество цифр в этом тексте.

Программа на языке Pascal

+1
Ответы (1)
  1. 20 июня, 09:40
    0
    Var

    str : string;

    i, num : integer;

    begin

    readln (str) ;

    num : = 0;

    for i : = 1 to length (str) do

    if str[i] in ['0' ... '9'] then

    num : = num + 1;

    writeln (num) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится текст. Слова разделяются пробелом. Ввод текста прекращается после нажатия на клавиатуре точки. Посчитать количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Вася сосчитал количество цифр на клавиатуре из него вычел количество букв "F" (заглавных и строчных) на всех клавишах умножил полученное число на количество стрелок и прибавил количество букв русского алфавита, начертание которых на клавиатуре
Ответы (1)
Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде блок-схемы или на языке программирования Pascal) 1. С клавиатуры вводятся три целых числа.
Ответы (2)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)