Задать вопрос
21 апреля, 00:32

Дана последовательность n целых чисел (n задается с клавиатуры) посчитать в ней среднее арифметическое квадратов четных чисел (pascal)

+4
Ответы (1)
  1. 21 апреля, 02:18
    0
    Var

    i, n, m:integer;

    k, s:longint;

    begin

    Write ('Задайте количество чисел: ') ; Read (n) ;

    s:=0; m:=0;

    Writeln ('Вводите числа ... ') ;

    for i:=1 to n do

    begin

    Read (k) ;

    if (k mod 2) = 0 then begin s:=s+k*k; Inc (m) end

    end;

    Writeln ('Среднее квадратов четных чисел: ', s/m:0:4)

    end.

    Тестовое решение:

    Задайте количество чисел: 7

    Вводите числа ...

    36

    -18

    15

    8

    14

    6

    9

    Среднее квадратов четных чисел: 383.2000
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность n целых чисел (n задается с клавиатуры) посчитать в ней среднее арифметическое квадратов четных чисел (pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вопрос №591394 (тип: C) Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b Входные данные: В первой строке вводятся два целых числа a и b (a
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)