Задать вопрос
19 января, 17:11

Даны два числа. Если их значения не равны, то присвоить каждому сумму этих

значений, а если равны, то присвоить числам нулевые значения. Вывести новые значения A

и B.

+3
Ответы (1)
  1. 19 января, 17:46
    0
    Var a, b, c:integer;

    begin

    writeln ('Введите 2 числа') ;

    read (a, b) ;

    if a=b then begin

    a:=0;

    b:=0;

    end else

    begin c:=a+b;

    a:=c;

    b:=c;

    end;

    writeln (a) ;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два числа. Если их значения не равны, то присвоить каждому сумму этих значений, а если равны, то присвоить числам нулевые значения. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Даны 2 переменные целого типа а и в если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить пременным нулевые значения. вывести новые значения а и в
Ответы (1)
Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной максимальное из этих значений, а если равны, то присвоить переменным нулевые значения.
Ответы (1)
В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. То-есть дан массив в которым есть нулевые значения. Например: 20330120 От Вас требуется создать массив из номеров этих нулевых значений.
Ответы (1)
Помогите надо написать программу в паскале. 1) координаты двух различных полей шахматной доски x1, y1, x2, y2 (целые числа, лежащие в диапазоне 1-8). Проверить истинность высказывания: "Ладья за один ход может перейти с одного поля на другое".
Ответы (1)