Задать вопрос
8 марта, 16:23

Дан массив B, состоящий из 15 элементов значения которого вводятся с клавиатуры. подсчитать сколько элементов массива положителлных и четных

+3
Ответы (1)
  1. 8 марта, 20:18
    0
    Program a;

    Var Mas : array [1 ... 15] of integer;

    b, c, i: integer;

    Begin

    K:=0;

    C:=0;

    For i:=1 to 15 do begin

    read (Mas[i]) ;

    If (Mas[i]>0) then inc (k) ;

    If ((Mas[i] mod 2) = 0) then inc (c) ;

    End;

    Writeln ('положительных - ', k) ;

    Writeln ('четных - ', c) ;

    End.

    (паскаль, не компилировал)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив B, состоящий из 15 элементов значения которого вводятся с клавиатуры. подсчитать сколько элементов массива положителлных и четных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)