Задать вопрос
4 июня, 10:31

Напишите программу, которая заполняет массив случайными целыми числами

, вводит с клавиатуры целое число N и копирует в новый массив все числа из исходного массива, для которых сумма значений всех цифр равна N.

+4
Ответы (1)
  1. 4 июня, 12:32
    0
    Program a1;

    var a, b: array [1 ... 10] of integer;

    n, i, k, sum, c: integer;

    begin

    Randomize;

    For i:=1 to 10 do

    begin

    a[i]:=random (100) ;

    write (a[i]:3) ;

    end;

    Readln (n) ;

    For i:=1 to 10 do

    begin

    k:=a[i];

    while k>0 do

    begin

    sum:=sum + (k mod 10) ;

    k:=k div 10;

    end;

    f (n=sum) then

    begin

    inc (c) ;

    b[c]:=a[i];

    end;

    end;

    for i:=1 to c do

    write (b[i]:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая заполняет массив случайными целыми числами , вводит с клавиатуры целое число N и копирует в новый массив все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)