Задать вопрос
19 июня, 09:58

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. Паскаль

+3
Ответы (1)
  1. 19 июня, 13:15
    0
    Program a1;

    var x, y, s: integer;

    begin

    read (x, y) ;

    write (x,'*', y,'=') ;

    while x>0 do

    begin

    If ((x mod 2) 0) then s:=s+y;

    x: = x div 2;

    y:=y+y;

    end;

    write (s) ;

    writeln () ;

    readln () ;

    end.

    Русский способ умножения
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы