Задать вопрос
15 декабря, 00:15

Помогите решить задачи:

1) С клавиатуры вводятся 3 целых числа. Определите количество положительных чисел в этом наборе.

2) С клавиатуры вводится натуральное число n. Вычислите сумму S=1+2 + ... + n.

3) Заполните элементы массива последовательностью чисел: 2,5,10,17,26, ...

+3
Ответы (1)
  1. 15 декабря, 01:00
    0
    1) program fagasg;

    var a, b, c, d: integer;

    begin

    Writeln ('Введите первое число') ;

    readln (a) ;

    Writeln ('Введите второе число') ;

    readln (b) ;

    Writeln ('Введите третье число') ;

    readln (c) ;

    d:=0;

    If a>0 then d:=d+1;

    If b>0 then d:=d+1;

    If c>0 then d:=d+1;

    Writeln ('Количество положительных чисел:', d) ;

    end.

    2) program gsggdfd;

    var n, s, i: integer;

    begin

    writeln ('Введите n') ;

    readln (n) ;

    s:=0;

    For i:=1 to n do

    S:=s+i;

    Writeln ('Сумма последовательности равна:', s) ;

    end.

    3) Program afsdgf;

    var A: Array[1 ... 100] of integer;

    i, h, s, l: integer;

    begin

    Writeln ('ведите размер массива') ;

    readln (h) ;

    s:=1;

    l:=1;

    For i:=1 to h do

    begin

    A[i]:=s+l;

    s:=s+2;

    writeln (A[i]) ;

    l:=A[i];

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи: 1) С клавиатуры вводятся 3 целых числа. Определите количество положительных чисел в этом наборе. 2) С клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)