Задать вопрос
21 марта, 02:49

Дано натуральное число Т - длительность прошедшего времени в

секундах. Вывести данное значение длительности в часах (HH), минутах (MM) и секундах (SS) в следующей форме: HH ч MM мин SS с.

Составить программу содержащую операторы ввода, вывода, присваивания.

+1
Ответы (1)
  1. 21 марта, 03:49
    0
    Program mnogohodovochka;

    var

    a, chas, sek, min:integer;

    begin

    writeln ('vvedite chislo') ;

    readln (a) ;

    chas:=a div 3600;

    min:=a mod 3600 div 60;

    sek:=a mod 3600 mod 60;

    writeln (chas, 'ч', min, 'мин', sek, 'с') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число Т - длительность прошедшего времени в секундах. Вывести данное значение длительности в часах (HH), минутах (MM) и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число T - длительность прошедшего времени в секундах. Вывести данное значение длительности в часах, минутах и секундах в следующей форме: НН ч ММ мин SS с. (паскаль)
Ответы (1)
1. Верное высказывание: а) Принтер - устройство ввода/вывода б) CD - ROM - устройство вывода в) Компакт-диск - устройство для хранения информации г) Клавиатура устройство ввода/вывода д) Монитор - устройство ввода
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)