Задать вопрос
8 ноября, 11:06

Паскаль. Задайте массив из 10 случайных целых чисел из интервала [-5; 5]. Определите сколько раз в массиве встречается число 3

+3
Ответы (1)
  1. 8 ноября, 12:04
    0
    program count3;

    const

    N=10;

    var a: array [1 ... N] of integer;

    i, count : integer;

    begin

    count:=0;

    cls;

    writeln ('Массив [-5; 5]') ;

    for i:=1 to N do begin

    A[i]:=random (11) - 5;

    write (A[i]:4) ;

    if A[i] = 3 then

    count:=count+1;

    end;

    writeln;

    writeln ('Количество троек в массиве : ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Задайте массив из 10 случайных целых чисел из интервала [-5; 5]. Определите сколько раз в массиве встречается число 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. В массиве А (11) случайных целых чисел (диапазон чисел [-10 ... 25]) определить: сумму элементов, которые кратны 5. 2. В массиве B (6) случайных целых чисел (диапазон чисел [-4 ... 53]) определить: количество элементов, которые меньше 7.
Ответы (1)
Язык Паскаль. №1 Дан массив, состоящий из n натуральных чисел. Образовать новый массив, элементами которого будут элементы исходного, оканчивающиеся на цифру k. №2 Дан масив целых числ. Найти в этом массиве минимальный элмент m и максимальный M.
Ответы (1)
Напишите решение задачи через паскаль. 1. Массив из 10 целых чисел из промежутка [10,20] задается с помощью гениратора случайных чисел. Вывести полученный массив в строку. Затем увеличить каждый элемент на 5.
Ответы (1)