Задать вопрос
5 июля, 01:37

Дана матрица целых чисел размером 5 на 6. Сформировать одномерный массив, каждый элемент которого равен произведению четных положительных элементов соответствующего столбца.

+2
Ответы (1)
  1. 5 июля, 02:43
    0
    Const

    n=5; m=6;

    var

    a:array[1 ... n, 1 ... m]of integer;

    b:array[1 ... m]of longint;

    k, i, j:integer;

    p:longint;

    begin

    for i:=1 to n do

    begin

    writeln;

    for j:=1 to m do

    begin

    a[i, j]:=random (20) - 10;

    write (a[i, j]:4) ;

    end;

    end;

    writeln;

    for j:=1 to m do

    begin

    p:=1;

    for i:=1 to n do

    if (a[i, j]mod 2=0) and (a[i, j]>0) then

    p:=p*a[i, j];

    if p1 then

    begin

    k:=k+1;

    b[k]:=p;

    end;

    end;

    for i:=1 to k do

    write (b[i]:8) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица целых чисел размером 5 на 6. Сформировать одномерный массив, каждый элемент которого равен произведению четных положительных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)