Задать вопрос
9 августа, 02:35

Программа Паскаль

Пользователь вводит число. Вывести на экран сколько раз в числе встречаются подряд идущие цифры 23

+2
Ответы (1)
  1. 9 августа, 06:25
    0
    Var

    s: string;

    i, n, k: integer;

    begin

    Write ('Введите число: ') ; Readln (s) ;

    k : = 0; n : = Length (s) ; i : = 1;

    repeat

    if s[i] + s[i + 1] = '23' then begin k : = k + 1; i : = i + 2 end

    else i : = i + 1

    until i > = n;

    Writeln ('Количество повторений "23" равно ', k)

    end.

    Тестовое решение:

    Введите число: 546423452323023

    Количество повторений "23" равно 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа Паскаль Пользователь вводит число. Вывести на экран сколько раз в числе встречаются подряд идущие цифры 23 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа должна выдавать ошибку если пользователь вводит ноль во втором числе, т. к на 0 делить нельзя и программа отправляет пользователя на повторный ввод, если пользователь умудряется допустить ошибку 3 раза подряд, то программа закрывается.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)