Задать вопрос
22 ноября, 02:52

Полное решение на Паскале: Увеличить каждую цифру трехзначного числа на 1. В случае 9 напишите 0

+5
Ответы (1)
  1. 22 ноября, 05:50
    0
    Uses Crt;

    var

    n, d1, d10, d100:integer;

    begin

    ClrScr;

    Write ('n=') ; Read (n) ;

    d1:=n mod 10; d100:=n div 100; d10: = (n div 10) mod 10;

    if d1=9 then d1:=0 else Inc (d1) ;

    if d10=9 then d10:=0 else Inc (d10) ;

    if d100=9 then d100:=0 else Inc (d100) ;

    Writeln (d100, d10, d1) ;

    ReadKey

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Полное решение на Паскале: Увеличить каждую цифру трехзначного числа на 1. В случае 9 напишите 0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите фрагмент алгоритма с ветвлением, который реализовывал бы следующую задачу: Если значение х будет такое же или меньше 15, то его необходимо увеличить в 3 раза, в противном случае в 3 раза надо увеличить y. Полное решение задачи как в Паскале
Ответы (1)
Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось 237. Найти число x. Решить на Паскале
Ответы (1)
Написать программу по "Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х." Язык Pascal. Заранее благодарна.
Ответы (1)
1. Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось число 237. Найти число x.
Ответы (1)
Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х
Ответы (2)