Задать вопрос
28 июля, 06:43

Создать процедуру, которая реализует решение предложенной задачи на паскале

Задан массив с количеством элементов N. Сформировать два массива: в первый включить элементы исходного массива с четными номерами, а во второй - с нечетными.

+1
Ответы (1)
  1. 28 июля, 08:36
    0
    Const

    n=20;

    type

    v=array[1 ... n] of integer;

    w=array[1 ... n div 2] of integer;

    var

    a:v;

    procedure FormW (var pa:w; pOdd:boolean) ;

    { При pOdd=true формируется массив из нечетных элементов,

    при false - из четных }

    var

    i, k:integer;

    begin

    k:=0;

    if pOdd then i:=1 else i:=2;

    while i<=n do begin

    Inc (k) ; pa[k]:=a[i]; i:=i+2

    end

    end;

    var

    b, c:w;

    i:integer;

    begin

    Randomize;

    Writeln ('Элементы исходного массива') ;

    for i:=1 to n do

    begin a[i]:=Random (50) ; Write (a[i]:3) end;

    Writeln;

    FormW (b, false) ;

    Writeln ('Массив из элементов с четными номерми') ;

    for i:=1 to (n div 2) do Write (b[i]:3) ;

    Writeln;

    FormW (c, true) ;

    Writeln ('Массив из элементов с нечетными номерми') ;

    for i:=1 to (n div 2) do Write (c[i]:3) ;

    Writeln

    end.

    Тестовое решение:

    Элементы исходного массива

    11 37 22 43 44 14 3 29 2 25 0 30 37 44 24 45 34 30 39 42

    Массив из элементов с четными номерми

    37 43 14 29 25 30 44 45 30 42

    Массив из элементов с нечетными номерми

    11 22 44 3 2 0 37 24 34 39
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать процедуру, которая реализует решение предложенной задачи на паскале Задан массив с количеством элементов N. Сформировать два ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)