Задать вопрос
4 декабря, 05:17

Вычислите 7116 + 4516. Ответ приведите в двоичной системе.

+2
Ответы (1)
  1. 4 декабря, 08:25
    0
    uses crt;

    function dec2bin (x:integer) : string;

    var s:string;

    begin s:='';

    while x>0 do

    begin

    s:=chr (ord ('0') + x mod 2) + s;

    x:=x div 2;

    end;

    dec2bin:=s;

    end;

    var a: integer;

    begin clrscr;

    a:=7116+4516;

    writeln ('ответ:', dec2bin (a)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислите 7116 + 4516. Ответ приведите в двоичной системе. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1. Выполните сложение в двоичной системе счисления: 101112 + 1011102 Результат запишите в двоичной системе счисления. 2. Выполните сложение в двоичной системе счисления: 11012 + 110112 Запишите ответ в двоичной системе счисления.
Ответы (1)
Перевести в десятичную систему: 10001,01 в двоичной системе. Перевести в восьмиричную систему: 55 в десятичной системе вычислить: (110111 в двоичной системе + 1011 в двоичной системе) * 101 в двоичной
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
Сколько единиц в двоичной записи числа 195? Сколько единиц в двоичной записи числа 173? Как представлено число 25 в двоичной системе счисления? Как представлено число 82 в двоичной системе счисления?
Ответы (1)