Задать вопрос
8 мая, 09:37

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры. Подсчитать среднее арифметическое элементов с нечетными номерами.

+4
Ответы (1)
  1. 8 мая, 12:25
    0
    Var a:array[1 ... 6] of integer; i, k, s:integer;

    begin

    for i:=1 to 6 do read (a[i]) ;

    k:=0; s:=0;

    for i:=1 to 6 do

    if i mod 2 = 1 then begin k:=k+1; s:=s+a[i]; end;

    writeln ('Среднее арифметическое элементов массива с нечетными номерами = ', s/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры. Подсчитать среднее арифметическое элементов с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Создать одномерный массив с помощью генератора случайных чисел, содержащий целые числа из диапазона от - 20 до + 80. К элементам с четными номерами прибавить А, а из элементов с нечетными номерами вычесть В. А и В вводятся с клавиатуры.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)