Задать вопрос
1 августа, 10:12

С клавиатуры вводится число до 1000. Определить какой сотне принадлежит число. Определить чётная или нечётная сумма цифр

+1
Ответы (1)
  1. 1 августа, 12:54
    0
    Var x, a, b, c, s: integer;

    begin

    write ('Введите число: ') ; readln (x) ;

    a : = x div 100;

    b : = (x div 10) mod 10;

    c : = x mod 10;

    s : = a + b + c;

    writeln ('Число принадлежит ', a, ' сотне') ;

    if (s mod 2 = 0) then writeln ('Сумма цифр четная')

    else writeln ('Сумма цифр нечетная') ;

    end.

    a - сотни

    b - десятки

    с - единицы

    Надеюсь я правильно тебя понял.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится число до 1000. Определить какой сотне принадлежит число. Определить чётная или нечётная сумма цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Дано натуральное число. Определить: а) сколько раз в нем встречается цифра а; б) количество его цифр, кратных z (значение z вводится с клавиатуры; z 2, 3, 4) ; в) сумму его цифр, больших a (значение a вводится с клавиатуры; 0 a 8) ;
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)