Задать вопрос
29 мая, 23:31

Дана строка символов

Сколько раз среди данных символов встречаться цифра?

паскаль. подскажите

+2
Ответы (1)
  1. 30 мая, 02:44
    0
    Var

    s:string;

    i, k:integer;

    begin

    s:='5*sin (x-pi/4) + (x-2.6) / (sqr (x) + 4*x-3) '; {чтобы не вводить}

    k:=0;

    for i:=1 to length (s) do

    if (s[i] in ['0' ... '9']) then k:=k+1;

    writeln ('Количество цифр равно ', k)

    end.

    Количество цифр равно 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка символов Сколько раз среди данных символов встречаться цифра? паскаль. подскажите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Паскаль 1) Задана строка, проверить есть ли в этой строке буква "а" 2) задана строка, проверить сколько раз встречаться в этой строке буква "м" 3) задана строка, удалить из этой строки все буквы "и"
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)