Задать вопрос
7 июля, 12:06

Составте програму, которая находит количество двузначных чисел, которые делятся на сумму своих цифр.

+4
Ответы (1)
  1. 7 июля, 13:51
    0
    var

    i, m, n, sum, k:Integer;

    Begin

    for i:=10 to 99 do

    begin

    m:=i mod 10;

    n:=i div 10;

    sum:=m+n;

    if (i mod sum = 0) then k:=k+1;

    end;

    Writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте програму, которая находит количество двузначных чисел, которые делятся на сумму своих цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
среди натуральных чисел, меньших некоторого n, вычислить сумму чисел, которые делятся на 3 и не делятся на 5. написаты програму на языке Паскаль.
Ответы (1)